aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMateja <mail@matejamaric.com>2021-02-13 14:20:34 +0100
committerMateja <mail@matejamaric.com>2021-02-13 14:20:34 +0100
commit2c60e8825c56861cac639e79e5cb74108b947617 (patch)
tree2713b20c7b5941c310e8d9557e24746c7bf9b42a /CMakeLists.txt
parenta36a47f018e2a214f0392bb5cf52edefeb5891c2 (diff)
downloaderender-2c60e8825c56861cac639e79e5cb74108b947617.tar.gz
erender-2c60e8825c56861cac639e79e5cb74108b947617.zip
Use CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ca28adf
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.13)
+project(erender)
+
+set( CMAKE_CXX_STANDARD 17 )
+
+aux_source_directory(./src/ SRC_LIST)
+add_executable(${PROJECT_NAME} ${SRC_LIST})
+
+add_subdirectory(external/SFML)
+target_include_directories(${PROJECT_NAME} PUBLIC external/SFML/include)
+target_link_directories(${PROJECT_NAME} PUBLIC external/SFML/lib)
+
+target_link_libraries(${PROJECT_NAME} sfml-graphics sfml-window sfml-system)