aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMateja <mail@matejamaric.com>2021-01-18 16:31:48 +0100
committerMateja <mail@matejamaric.com>2021-01-18 16:31:48 +0100
commit737e2266d0cf5940ef993fd09deaec57a31c65c4 (patch)
tree089d461ba06779c9a6906b3bf5aee4548d80703e /CMakeLists.txt
parentb2b63dd7d8f2987c1cc8ff07ec2173637c002af3 (diff)
downloadscanline-render-737e2266d0cf5940ef993fd09deaec57a31c65c4.tar.gz
scanline-render-737e2266d0cf5940ef993fd09deaec57a31c65c4.zip
Use CMake instead of Makefile.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..5786cbb
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required(VERSION 3.13)
+project(scanline-render)
+
+set( CMAKE_CXX_STANDARD 17 )
+
+add_executable( ${PROJECT_NAME} main.cpp )